uuzih VHDL eehadisaae Xilinx ISE Design Suite
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* Xilinx ISE Design Suite 13.2, i Taann: http://www.xilinx.com/support/download/index.htm.

* jpnansuuzii Xilinx ISE eghadiuniamsaiivaaldain:
http://www.xilinx.com/support/documentation/dt_isel3-2.htm.

$1. 5uau!

1. 1Ja ISE Project Navigator: Start > All Programs > Xilinx ISE Design Suite > ISE Design Tools >
Project Navigator.

Project Navigator ta@aaa3ii 1.

e File Edit View Project Source Process Tools Window Layout Help B@IE
DAEFLXxabXxwa]| "[2PeR BN ==0=[,nir L9
Start 08 x| B
® Redraw All Windows
Welcome to the ISE® Design -
Suite =
. 5]
Project commands B ISE Design Suite 13 Release Overview
ye
[Dpen Project...] [Project Bmwser...] y-l ISE Design Suite Highlights

[New Project... ] [ Open BExample... ]

> Introducing the 7 Series Device Support
Recent projects > Begin designing in Kintex™ -7 and Virtex®-7 devices today
> Includes Intelligent Clock Gating to reduce dynamic power

1

Double click on a project in the list below
to open » Team Design Flow
| | > Improved productivity in embedded design, implementation design flow, and verification.

> |EEE P1735 encryption flow for simulation inter-operability
> Cadence® AXl Bus Function Model (BFM), sold separately, to verify your AXl4 P

Additional resources

IP Updates: Click here for the IP Release Notes library updates and new products
ISE Design Suite InfoCenter

Key New Features in Project Navigator

Tutorials on the Web Resources
Design Resources
Application Notes e P nnime AL AinAn i A ke men Rini i Im IO Caime Cuies S amen 2
| Tl r
- ISE Design Suite InfoCenter B ‘
Console 08X

« 1 »
Console |° Errors I_ﬁ Warnings |Lii Find in Files Resur‘ts‘

Redraw all the windows

Figure 1: ISE Project Navigator
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http://www.xilinx.com/support/download/index.htm
http://www.xilinx.com/support/documentation/dt_ise13-2.htm

$2. a$alusonlva.

a) File > New Project.
n111@19 New Project Wizard veidadiuan.

v v Y
b) Tugeq Location, aeni Nazify lWdaagvealusmaiiadll. de mu Srdeemaiu g3y

c:\xilinx_tutorial Al¥ld c:\xilinx_tutorial.

¢) Tusoe Name, ldFeT1lsnaslel Glugﬂ‘ﬁ 2 daieTsianT courage®l,

d) #5299 11%03 Top-Level Source Type 1aon HDL og udnan Next.

e New Project Wizarc

Create New Project

Specify project location and type.

Enter a name, locations, and comment for the project

Name: |couragel]1

Location: |C:\xiIinx_tutorial\courage[]l

Working Directory: | C:\linx_tutorial\courage0l

Description:

Select the type of top-level source for the project

Top-level source type:

'HDL

Figure 2: New Project Wizard

e) Tunthang Project Settings, tapnaiae lil:

Product Category: A1l

Family: Spartan3A and Spartan3AN
Device: XC3S700A

Package: FG484
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file:///c:/xilinx_tutorial

Speed: -4
Synthesis Tool: XST (VHDL/Verilog)
Simulator: ISim (VHDL/Verilog)

f) ndn Next, ud1 Finish tieas1alalsionlu.

$3. tin g VEDL sl sien.

a) Project > New Source ..
9y
1111919 New Source Wizard aziaduan,

b) 18en VHDL Module 1151 source type.

¢) ld Logics00 luie file name.
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File Edit View Project Source Process Tools Window Layout Help

DAEFIL [ ¥nbxlval {229 R 2RI

|Des'rgn +048 x|

[ | View: (@) 18 mplementation () & Simulation

(] [Top Module: |

Hierarchy .

| @ couragedt . New Source Wizard

& = £ xc35700a-4fg484

Select Source Type

B The view currently conta

E project using the toolba Select source type, file name and its location.

menu, and by using the £ IP (CORE Generator & Architecture Wiz:

[&] Schematic

[2] User Document
Verilog Module
[#] Verilog Test Fixture File name:
(i VHDL Module Logicsto
[ VHDL Library
[¥] VHDL Package
E VHDL Test Bench |C:\xiIinx_tutorial\courage[]l | [;]

¥ Embedded Processor

Use:

* New Source: To €

T2 No Processes Running

No single design module is
@ Design Utilities

Location:

HHHSE| v

Add to project

I ]

More Info l Next H Cancel ]

| & Start | B3 Design |® Files [P .I
Figure 3: New Source Wizard

d) Ta x@, x1, nag x2 d1%35u in uaz yo uaz y1 $ 151 out Awuaadlugili 4 nazaan Next.

198 vhdl (Logics00.vhd) «'nzgﬂﬁ%qﬁumuazlﬁwfh"lﬂ“luTﬂmﬂ.

e) TPOE
y@ <= NOT (x0@ AND x1);
yl <= NOT (x1 OR x2);

' . . 4 4 o 9 . @
s34 begin uaz end ¥v3 architecture MoussewMsFoUUDI WY IUUDYaVDI Logics00, Aduaag

Tuguii s.

f) File > Save.
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g) A57980U9 11 Project > Manual Compile Order lildgniden.

Define Module

Specify ports for module.
Entity name | Logics00

Architecture name |E1ehaviorat

Port Name Direction ~ Bus ~ MSB LSB &
X0 in 4
xl in v I
x2 in P! i
y0 out G
y1 &
in &
in M
in d [ f

Figure 4: New Source Wizard: Define Module
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40
41
42
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44
45
46

library IEEE;
use :EEE.STD_LOG:C_1164.ALL;

—— Uncomment the following library declaration if using
—-- arithmetic functions with Signed or Unsigned values
——use IEEE.NUMERIC STD.ALL;

—— Uncomment the following library declaration if instantiating
—— any Xilinx primitives in this code.

——library UNISIM;

——use UNISIM.VComponents.all;

entity Logics00 is
Port ( %0 : in STD LOGIC;
x1 : in STD LOGIC;
%2 : in STD LOGIC;
y0 : out STD LOGIC;
¥l : out STD LOGIC);
end Logics00;

architecture Behavioral of Logics00 is
begin

v0 <= NOT (x0 END x1);
| ¥l <= NOT (x1 OR x2);

end Behavioral:

Figure 5: VHDL code of Logics00
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& ISE Project Navigator (0.61xd) - C:wilinx_tutorial\courage01\coura

File Edit View Iﬁl Source Process Tools Window

O & H ¥~ || @ New Source.. 2 =

|Design § {2 Add Source... JE
[ | View: @) {8} imple [sz] Add Copy of Source... I
& | Hierarchy

% courage0l New VHDL Library...

2, EN Ry, Manual Compile Order

E ~[idefk Logi  Import Custom Compile File List..

Disable Hierarchy Reparsing

& Force Hierarchy Reparse

Cleanup Project Files...

Archive...

Generate Tcl Script..

Design Goals & Strategies...
2 Mo Processes R g 9

Processes: Logics i Design Summary/Reports

I Design S Design Properties...

|59 2|

- %F  Nacian | litiac

=y
Figure 6: Verify that Manual Compile Order is
unchecked.

$4. Synthesize your design.
a) lu Hierarchy pane %94 Project Navigator Design Panel, Lﬁ@ﬂiu@aﬁmﬁu%: Logics0e.

4 -d' o . .
b) 1u Processes pane, Ieubanan Synthesize. 931/ 7 (Fung 1aon Implementation View)

a

c) Lﬁ’aﬁ]z@ RTL schematic 910 HDL code, v#¥ (ﬂﬁﬂlﬂ?@Q‘HMW‘Ulﬂﬁﬁlﬂ Synthesize lu Processes

Y
pane uae autUanan View RTL Schematic.

d) 11111819 Set RTL/Tech Viewer Setup Mode 3z1da¥uan. tien Start with the Explorer

Wizard uag aan OK.

=

e) Tuwivh Create RTL Schematic, tdon Logicsee uaz Add rieiden Tugaiazg.

f) aan Create Schematic.

Y
111819 RTL Schematic viewer 11#a4 schematic 910 VHDL code. 1518305 n1aenudiuaiguazgaiu
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Usznoumeluvesiuld Tas Adnvua uag 1don Show Block Contents. 31l 9 uaz 10.

o ISE Project Navigator (0.61xd) - C:vilin tutorial\courage01\courag
[£) File Edit View Project Source Process Tools Window |

O2 9 | ¥KDEXx|wvwa| 2R AR
Design =05
View: @ Implementation O k& simulation
Hierarchy

courage0l
= £ xc3s700a-4fg484
“ Mgl Logics00 - Behavioral (Logics00.vhd)

v
I

5

H|© 0 ||| e

P2 No Processes Running

O@|&F # & » |18

Processes: Logics00 - Behavioral
~E  Design Summary/Reports
=%  Design Utilities

B % User Constraints

H| &8 [5E| v

[&  View RTL Schematic

[ View Technology Schematic

f2  Check Syntax
~ @)  Generate Post-Synthesis Simulation Model

Figure 7: Hierarchy and Processes panes
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. ISE Project Navigator (0.61xd) - Chxilinx_tutorial\courage01\courage0l.xise - [Logics00 (RTL2)] L .l"":' | = ‘ﬁl

. File Edit View Project Source Process Tools Window Layout Help

D ¥ - f L nl: B S -;u:' P(
Design 08 x| [k
[ | View: @ £} Implementation & Simulation

| | Hierarchy

5| - couragenl
= £4 xc35700a-4fg484

['de%: Logics00 - Behavioral (Logics00.vhd)

£l
# | 3 No Processes Running

70 Processes: Logics00 - Behavioral i

P

Z  Design Summary/Reports
{|® % Design Utilities
— | 5%  User Constraints
= P Synthesize - XST L : 0 0
[ View RTL Schematic : 0 g | CS
View Technology Schematic
2  Check Syntax
f2  Generate Post-Synthesis Simulation Model  ~

1

& Start | B2 Design | Files [} Libraries ized) /¢ LogicsO0.ngr:1 & Logicsno (RTL2) B |T|
View by Category +05 x
Design Objects of Top Level Block Properties: (No Selection)
Instances Pins Signals Name Value
& Logics00
|E] console | @ Errors | 1 Warnings | ip& Find in Files Results | £ View by Category
[444,56]

Figure 8: RTL Schematic
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Show All Block Inputs
LO ICSOO Show All Block Outputs
g Show All Block Inputs/Outputs
> Add Input Cone... Alt+5Shift+]
<0} Add Output Cone... Alt+5hift+0

0

1 New Schematic With Selected Objects
Og Remove Selected Objects

Hide Block Contents

Open Source of Selected Instance
Open All HDL Source Files

Preferences...

Logics00

Figure 9: You can see contents inside a block in RTL Schematic viewer.
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Logics00:1

0

y1 or0000 imp_y1 or00001

Iy

Logics00

Figure 10: Logic gates inside Logics00 block.

$5. Simulate your first design.

a) Project > New Source .
Y
H111819 New Source Wizard ilatiuun.

b) 1N VHDL Test Bench uay Wui: Logics@o_tb tieiiuye 11§, adn Next, Next, uaz Finish.
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& New Source Wizard

Select Source Type

Select source type, file name and its location.
€% ChipScope Definition and Connectio =
[= Implementation Constraints File

4 1P (CORE Generator & Architecture V
MEM File

[=] Schematic File name:

[=] User Document |Logics[][]_tb

Verilog Module

] Verilog Test Fixture
m VHDL Module |C:\xilinx_tutorial\couraget]l
[y VHDL Library
[F] VHDL Package

P VHDL Test Bench |

¥ Embedded Processor -
| Add to project

Location:

| Next ”C.ancel

-- Company:
-- Engineer:

-- Create Date: 16:28:19 08/16/2011

-- Design Name:

-- Module Name: C:/xilinx_tutorial/courage@l/Logics@0_tb.vhd
-- Project Name: courageol

-- Target Device:

-- Tool versions:

-- Description:

-- VHDL Test Bench Created by ISE for module: Logicseo
-- Dependencies:

-- Revision:
-- Revision 0.01 - File Created
-- Additional Comments:

-- Notes:

-- This testbench has been automatically generated using types std_logic and

-- std_logic_vector for the ports of the unit under test. Xilinx recommends

-- that these types always be used for the top-level I/O of a design in order

-- to guarantee that the testbench will bind correctly to the post-implementation
-- simulation model.

LIBRARY ieee;

USE ieee.std_logic_1164.ALL;
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-- Uncomment the following library declaration if using
-- arithmetic functions with Signed or Unsigned values
--USE ieee.numeric_std.ALL;

ENTITY Logicse@e_tb IS
END Logicsee_tb;

ARCHITECTURE behavior OF Logicse@@_tb IS

-- Component Declaration for the Unit Under Test (UUT)

COMPONENT Logicseo

PORT (
x0 : IN std_logic;
x1 : IN std_logic;
x2 : IN std_logic;
yo : OUT std_logic;
yl : OUT std_logic
)

END COMPONENT;

--Inputs

signal x0 : std_logic := '1';
signal x1 : std_logic := '@';
signal x2 : std_logic := '@';

--Outputs
signal yo : std_logic;
signal y1 : std_logic;
-- No clocks detected in port list. Replace <clock> below with
-- appropriate port name

constant clk_period : time := 1000 ns;

BEGIN

-- Instantiate the Unit Under Test (UUT)
uut: Logicsee PORT MAP (

X0 => x0,
x1 => x1,
X2 => X2,
yo => ye,
yl =>yl
)s

-- Clock process definitions
clk_process :process
begin
clk_loop : loop
wait for clk_period/2;

X0 <= '0';
wait for clk_period/2;
X0 <= '1";

end loop clk_loop;
end process;

-- Stimulus process
stim_proc: process
begin

x1_loop : loop

130f 16 T.K. Comp. Eng. KKU



x1 <= '0';
wait for clk_period/4;
x1 <= '1";
wait for clk_period/4;
end loop x1_loop;
end process;

X2_proc: process

begin
X2 <= '@';
wait for clk_period;
x2 <= '1';

wait for clk_period;
end process;

END;

d) save. Tu View panel, fauaaslugildreas, idon Simulation. lu Hierarchy pane, 1aon
Logics0o_tb.

|Design HEIEX| i
[ | View: () 18} implementation (Q) &8 Simulation v
i Behavioral E| =
% Hierarchy
& | @ couragenl
E =8 €3 xc3s700a-4fg484 z
2% ¥ Logics00_tb - behavior (Logics00_tb.vh 4
%
- .
p
@
)
4| 1] | »

e) 1u Processes pane, Y1y ISim Simulator uay idon Simulate Behavioral Model uag Aanvdn.

Processes: Logics00_tb - behavior
Elﬁ' 1Sim Simulator
~®)  Behavioral Check Syntax

(2%
5 im

Simulate Behavioral Model

91 pop-up menu, 19en Process Properties ..

1 Y 1
iiien1Ana Process Properties 1iavuun 1iiasu Simulation Run Time iilu 4000 ns. adn OK.

f) duianan Simulate Behavioral Model.

Y
N1A149 ISim zidlauan LEPIMUDITY NN a1 (U xO0, x1, x2, y0, uag yl).
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B8 Process Properties - ISim Properties . [&I

Switch Name Property Name Value i

Use Custom Simulation Command File
Custom Simulation Command File

-incremental | Incremental Compilation v
-nodebug Compile for HDL Debugging v |
Use Custom Project File 3
-prj Custom Project Filename
Run for Specified Time v
Simulation Run Time 4000 ns
Waveform Database Filename _tutorial\courage01\Logics00_tb_isim_beh.wdb |:|

Use Custom Waveform Configuration File
Custom Waveform Configuration File
Other Compiler Options

-rangecheck Value Range Check

ol
Likraru for Warilon Snnrcac

Property display level: |Advanced B + | Display switch names | Default |

[ OK ] | Cancel Apply | Help |
ﬁ S
- ________a - T W — - — T — - 4
£x TSim (0.61xd) - [Defaultwefg] o
7 File Edit View Simulation Window Llayout Help
DAEE 4B0X®|0 | M@ mE Mo
Instances and Processes  + 0 & X || Objects «08 x| #
Simulation Objects for logics00_tb y-
] ®
Instance and Process Name [ (S e
I logics00 tb Ic|| Object Name Value ‘
4 std_logic 1164 st 1% 0
1%
1 x2

[:3 ¥
1% y1
I clk period 1000000 ps

Ik OO

]

< 1l b < ol < ol 4 e

£ Tnstan. Memory | /E] 5 rlil <« I v || Default.wefg 8

Console 08 x

g)View > Zoom > To Full View iioguaguyadulusiananiimua.

150f16 T.K. Comp. Eng. KKU



ODh|i AR?| 22 F ANENERT-N-" N Sl "I+ I %S 1.DDUSE|QE | £3 Re-launch

3.009994 us

i
S

e ——
_-“_-_
e

4
= v

4
o [ <
uuzi1 VHDL s1a5aieedu Atmmiivazasy.

16 Of 16 T.K. Comp. Eng. KKU



